Grails 2.1 to 2.2 Upgrade command error

Upgrading a project from Grails 2.1.x to 2.2.x by running a grails upgrade you might run into an error of the kind: | Error Error executing script Upgrade: Could not find matching constructor for: org.codehaus.groovy.grails.compiler.support.GrailsResourceLoader([Lorg.codehaus.groovy.grails.io.support.Resource;) (Use –stacktrace to see the full trace) Fix is to refresh you dependencies first by running grails refresh-dependencies. Hope itContinue reading “Grails 2.1 to 2.2 Upgrade command error”